Realtek 8192 losing connection in Linux

One problem I’ve had with my laptop ever since I bought it is the Realtek 8192 wireless chip losing connection and requiring a reboot to reconnect. This happens in both Ubuntu and Windows, though Windows is at least as likely to never connect in the first place.

I finally seem to have come up with a method of recovering the wireless connection in Linux without having to reboot. Merely restarting the network does not work, it requires unloading and reloading the driver, for which I’m using the following script:

#!/bin/bash
sudo service network-manager stop
sleep 5
echo "Remove Wireless driver"
sudo modprobe -r rtl8192se
sleep 5
echo "Reload Wireless driver"
sudo modprobe rtl8192se
sleep 5
sudo service network-manager start

The wireless has actually been working for the last week so I’ve only just had a chance to test this script and it seems to work. The delays may be excessive, but it’s still faster than rebooting and then restarting all my software.

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.